了解 Spring 的 @Required 註解:傳統觀點

https://dev.to/tiuwill/understanding-springs-required-annotation-a-legacy-perspective-5il

@Required 註釋已自 Spring Framework 5 起被廢棄,但在舊項目中仍然常見。為何重要?許多項目並非基於新版本的 Spring Framework 建立,您可能正在或未來將要處理舊項目。閱讀此文後,您將了解此註釋的功能和使用方式。它告訴 Spring 特定 bean 屬性為必需,並在配置時檢查其是否設置。如今,您可以透過將依賴關係置於 bean 構造函數中或使用 @Autowired 註釋來實現此功能。

via DEV Community

June 7, 2024 at 05:46AM

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *